Table properties pane


< Back to working with projects


Toolbar > New project
Click on this icon to start a new empty project. This is the starting point for any AppGini application. You will have an empty project that contains only an empty database and predefined default styles. back to top

Table properties > Table view title
The table view title is the title of the table as it will appear in the pages of the generated PHP application. back to top

Toolbar > Open Project
Click on this icon to open a previously saved project.back to top

Toolbar > Save Project
Click on this icon to save the currently open project. If you haven't saved your project before, you'll be prompted for a file name and location.back to top

Toolbar > Project Properties
Click on this icon to bring the Project Properties area where you can specify the database connection parameters. back to top

Toolbar > Application Theme
Click on this icon to preview (and edit) the theme of your application. back to top

Toolbar > New Table
Click on this icon to add a new table to your database. back to top

Toolbar > New Field
Click on this icon to add a new field to the current table. back to top

Toolbar > Delete Selected Table/Field
Click on this icon to remove the highlighted field or table from your database.back to top

Toolbar > Move Table/Field up
Click on this icon to move the highlighted field down/up in the current table. back to top

Toolbar > Move Table/Field up
Click on this icon to move the highlighted field down/up in the current table. back to top

Toolbar > Generate PHP Code
Click on this icon to let AppGini generate the PHP code for your web database application based on the database, tables and fields you defined in your project. You'll be prompted for a location to save the generated files. back to top

Toolbar > Preferences
Click on this icon to open the preferences window, where you can set various AppGini options.back to top

Toolbar > Help
Click on this icon to view the online help.back to top

Toolbar > About AppGini
Click on this icon to view version and contact information for AppGini back to top

Toolbar > Exit
Click on this icon to quit the program. If you have an open project, you'll be asked to save your work first. back to top

Table view and detail view
This is a screen shot that demonstrates an example of how the table view and the detail view would look like after generating your application. back to top

Table view and detail view
This is a screen shot that demonstrates an example of how the table view and the detail view would look like after generating your application. back to top

Project Browser Window
This is the project browser window where you can see a list of the database, table and field names in the current project arranged in a hierarchical view. Click on any item on the window to view and edit its properties in the Properties window. back to top

Table properties > Table view title
The table view title is the title of the table as it will appear in the pages of the generated PHP application. back to top

Table properties > Description
If you provide a description for the table, this description will be displayed in the home page of the generated application. You can use HTML code in this description. back to top

Table properties > Records per page
The number of records that appear on one page in the generated PHP application. Records are displayed as horizontal rows of a table. If you put a large number here, your application user might have to scroll down the page to view records. back to top

Table properties > Show quick search box
If you want to display a quick search box above the table view, check this option. When the user enters a word in that search box and clicks the search button or presses Enter key, the table is searched for matches in any field. This is much easier than the advanced filters if you want a simple search technique. back to top

Table properties > Default sort by,Descendingly
If you'd like records in the table view sorted by default, select the field that you want to sort by from the 'Default sort by' drop down. The default sorting direction is ascendingly (A-Z, 0-9) unless you check the 'Descendingly' option. If you don't want any default sorting, select 'None' from the 'Default sort by' drop down. back to top

Table properties > Allow sorting
This option controls whether users are allowed to sort records in the table or not. Note that this doesn't affect the table in the database, only the query that displays data to the user.back to top

Table properties > Allow filters
This option controls whether users are allowed to filter records in the table or not. Note that this doesn't affect the table in the database, only the query that displays data to the user. back to top

Table properties > Allow saving data to CSV files
If you check this option, users will see a Save button above the table view that allows them to save data as a CSV file (Comma-Separated values). back to top

Table properties > Allow print-view
This option controls whether users are allowed to view the table data as a printer-friendly page. back to top

Table properties > Allow users to save filters
If you check this option, users will see a Save button in the filters page. If they click this Save button, they will view some HTML code that they can copy and paste to any external web page. This HTML code creates a button linking users to the filtered table view (without having to redefine filters). TIP: Usually, you would want to allow this option temporarily till all users have determined which preset filters they want to save. Later on, you can disable this option and regenerate the code. back to top

Table properties > Hide link in homepage
If checked, this table will not have a link to it in the homepage of the generated application. Usually used with the option 'Hide link in navigation menu' checked as well. This is useful for example if this is a child table and you want users to access it only from its parent table rather than directly through a link. back to top

Table properties > Allow mass delete
This option controls whether users who have permission to delete records can delete multiple records at once. back to top

Table properties >Filter before showing table view
When this option is checked, users see the filters page first before seeing the table data. This is useful if you want users to search the table and display the search results to them. back to top

Table properties > Hide link in navigation menu
If checked, this table will not have a link to it in the navigation menu of the generated application. Usually used with the option 'Hide link in homepage' checked as well. This is useful for example if this is a child table and you want users to access it only from its parent table rather than directly through a link. back to top

Table properties > Detail view title
The title of the detail view form. The detail view form is where users can edit and add data to the table. back to top

Table properties > Redirect after insert
If you type a web address here, users will be sent to that address after they insert a new record. If you leave this box empty, users will be sent to the table view page. If you add the characters #ID# as part of the web address, they will get replaced by the primary key value of the newly inserted record. For example, these are valid addresses that you can put into the box: thanks.html back to top

Table properties > Display a link to children records from
If you have lookup fields in other tables whose parent table is set to the current table, you'll find them listed here as children tables. If you check any of the children tables listed here, users will see a link to that table displayed in the detail view when a record is selected from the current (parent) table. This link displays records of the child table related to the current parent record. For example, you may have an artists table, and a songs table. The songs table has an 'Artist' field whose parent table is the artists table. Using this feature, users who select an artist from the artists table will see a 'songs' link in the detail view of the selected artist. Clicking on that songs link, users will see all the songs that belong to the selected artist. back to top

Table properties > Enable detail view
Use this option to control whether users can see the detail view or not. back to top

Table properties > Delete records even if they have children records
The default behavior when a user tries to delete a record is that the AppGini-generated code will check to see if this record has one or more child records (records that have lookup fields pointing to the record to be deleted). If one or more children are found, the record is not deleted. If you check this option, the above check will still be performed, but the user will be prompted to confirm deletion of the record. If the user confirms, the record will be deleted. In this case, children records will not be deleted, but will have no parent record. back to top

Table properties > Allow detail print-view
If you check this option, users will see a 'Print preview' button in the detail view when selecting a record. Clicking that button would display a printer-friendly view of the selected record. back to top

Table properties > Display detail view in a separate page
If you check this option, the detail view (the form where users can add or insert records) will be displayed in a separate page instead of below the table view. back to top

Table properties > Hide 'Save As Copy' when editing
By default, when a user selects a record for editing, the 'Save As Copy' button is displayed in the detail view so that the user can save a copy of the selected field. Checking this option would disable this behavior and the 'Save As Copy' button won't be displayed. back to top

Table properties > Parent/Children settings
This feature is enabled only if the current table has children tables. Displays settings for showing the children records in the detail view. back to top

Table properties >Table icon
Click this icon to select a new icon for the table. The table icon is displayed in the homepage and the navigation menu of the generated application.back to top

Search box
You can use this box to search for a specific table/field by typing its name or part of it then clicking the lens icon. Click it again to move to the next matching table/field. back to top

File menu
Includes commands for starting a new project, opening an existing one, importing from an existing MySQL database or a CSV file, and saving current project. back to top

Tables menu
Includes commands for adding and deleting tables and fields from the current project.back to top

Project menu
Includes commands for generating the web application, and for changing the application theme.back to top

Help menu
Includes various help resourcesback to top

Copy
Copies the selected table or field to the clipboardback to top

Paste
Pastes a copy of the field or table in the clipboard to the project back to top

Toggle Highlight
Marks/unmarks the current table or field with a yellow background for easily returning to it later on.back to top

Activate/deactivate help for toolbar icons
Click this icon to switch to help mode where clicking any icon would show its help rather than execute its action. Click again to switch to normal mode.back to top


< Back to working with projects